Online Interface Agents 8.3
Optional online interfaces for message based collection and distribution.
OP = On-premise, CS= Cloud Service
General Availability
Package | Type | Rel. | Description |
|---|---|---|---|
AMQP Collection
| Online | 7.3.2.0 | Collects messages from Rabbit Message Queues using the AMQ (Advanced Message Queueing) Protocol. A list of brokers to collect from can be configured for each agent. Optionally, TLS can be enabled. Reference: |
APN
| Online | 8.0.2.2 | The APN agent allows push notifications to be sent to mobile devices using Apple certificates. Reference:
|
Diameter | Online | 6.0.0.0 | The Diameter agents enable a workflow to act as a Diameter server, a Diameter client, or as a Diameter Proxy agent, by applying the Diameter Base Protocol. Supports TCP and SCTP as transport protocols over IPv4 and IPv6. Import and export of AVP and Command specifications supports two formats: ABNF (Augmented Backus-Naur Format) and XML (eXtensible Markup Language). Reference:
|
Disk Collection Realtime
| Online | 7.3.1.0, 8.0.40 | Continuously scans and collects files from local disk. Uses the Standard File Collection Functions and File Collection Functions Available for Realtime Only. Based on the Batch Disk Collection Agent. Please refer to that package for more information. |
Disk Forwarding Realtime | Online | 7.3.1.0 | Forwards files to local disk according to configured file closure criteria. Based on the Batch Disk Forwarding Agent. Please refer to that package for more information. |
FTP Collection
| Online | 8.0.4.0 | Continuously scans and collects files from remote file system using the standard FTP (RFC 959) protocol. Uses the Standard File Collection Functions and File Collection Functions Available for Realtime Only. Based on the Batch FTP Collection Agent. Please refer to that package for more information. |
FTP Forwarding | Online | 8.0.4.0 | Forwards files to remote file system using the standard FTP (RFC 959) protocol. Uses the Standard File Forwarding Functions and File Forwarding Functions Available for Realtime Only. Based on the Batch FTP Forwarding Agent. Please refer to that package for more information. |
Firebase FCM Fwd | Online | 8.1.3 | Enables push notifications to be sent to mobile devices using Firebase Cloud Messaging. Reference:
|
GTP' | Online | 6.0.0.0 | Collects charging messages and datagrams from GSM agents (SGSN and GGSN) using the GPRS Tunneling protocol, via TCP or UDP. The agent can optionally check for duplicates and sequence numbers, and a configurable number of nodes to collect from can be defined. To assure that data is transmitted properly, a subsequent Analysis or Aggregation agent can be configured to send acknowledgement to the collection agent. References:
|
HICAP
| Online | 6.1, 6.3 | Collects data from an Automatic Message Account Transmitter (AMAT) using the High Capacity AMATPS (Automatic Message Account Teleprocessing) API over an RPC interface. Can generate trace and debug files for testing purposes that comply to the standard (see reference below). The agent is available on RedHat Enterprise Linux only, as it is dependent on third parties that are only available for this particular OS. Reference:
|
HTTP | Online | 6.0.0.0 | The collection agent is based on the Batch HTTP Collection Agent. Please refer to that package for more information. |
HTTP Client APL functions | Online | 8.3 | Enables Analysis/Aggregation agents to act as HTTP/2 clients using APL functions. |
HTTP2 Client | Online | 8.3 | Enables a workflow to communicate requests to HTTP/2 servers. Supports both HTTP/1 and HTTP/2. |
HTTP2 Server | Online | 8.3 | Enables a workflow to act as an HTTP/2 Server. Supports both HTTP/1 and HTTP/2. References:
|
IBM MQ | Online | 6.1.0.0 | Acts as a client to an IBM Websphere MQ Queue Manager. Collects messages from a configurable number of message queues, topics or durable subscriptions. Reference:
|
IPDR | Online | 7.3.5.0, 8.0.3.0 | Collects IP based service usage information, performance and usage measurement records (IPDRs) using the IPDR streaming protocol. A list of sources to collect from can be configured in the GUI, or through a file. Reference: |
Kafka | Online | 7.1.0.0 | Collection and Forwarding of Apache Kafka messages. |
LDAP Agent | Online | 8.0.5.0 | A processing agent acting as a client to LDAP (Lightweight Directory Access Protocol ) Servers. A list of servers to connect to can be configured, in either round robin or failover mode. In additions to standard authentication using security credentials, TLS - with or without keys - can be enabled. Supported operations:
Reference:
|
MQTT Client | Online | 7.3.5.0 | Collects data from MQTT (Message Queue Telemetry Transport) servers using the TCP/IP protocol. A list of brokers can be configured, as well as a list of topics to subscribe to. TLS can be enabled. Reference: |
MSMQ | Online | 8.1.4 | Collection Processing Reference: |
Netflow | Online | 6.0.0.0 | Collects traffic data from one or several Cisco routers. Support Netflow versions 1, 5, 7, 8, 9, and 10. The agent binds on a specific port and IP address, and can be configured to only include predefined hosts. Routers using more than one interface IP address are configured to have a main IP address. Warnings on sequence gaps can be enabled. Reference:
|
NordPool | Online | 8.0.4.0 | Collects information from the NordPool Intraday API version 2.0. The agent can subscribe to any topic. |
Open API Profile | Online | 8.0 | The Profile enables definition of Open API specifications, that can be used with the HTTP/2 agents. Direct import from the UI is possible. Additional files defined by the specification will automatically be included. |
Python Connector
| Online | 8.0.1.0; 7.3.4.0 | Enables test and exploration of workflows using an external exploration tool, for instance Jupyter Notebook. Gives the exploration tool access to all the UDRs, routes, APL functions etc that are part of the workflow. Supports interactive mode. |
Python RT Processing | Online | 7.3.2.0 | Enables processing using Python, as an alternative to APL. Includes the possibility to define several different interpreters and working directories using the Interpreter Profile. |
Radius | Online | 6.0.0.0 | Server Client Reference:
|
REST Client | Online | 8.0.0.0 | The REST Client processing agent queries an HTTP API using any of the methods specified in the RFC 2616. If the REST API's schema is described in JSON or YAML files, the OpenAPI profile can be used to automatically generate UDR structures. Reference:
|
REST Server | Online | 8.0.5.0 | The REST Server agent receives HTTP requests from client applications. Responses or acknowledgements are configured in Aggregation of Analysis agents connected to the REST Server agent. OAuth 2.0 protocol for authorization can optionally be deployed. If the REST API's schema is described in JSON or YAML files, the OpenAPI profile can be used to automatically generate UDR structures. Reference: |
Salesforce
| Online | 8.0.4.0 | Connects to Salesforce as a client and listens to changes on specific objects (topics). |
SCP Collection
| Online | 8.0.4.0 | Continuously scans and collects files from remote file system using the SCP protocol over SSH2. Uses the Standard File Collection Functions and File Collection Functions Available for Realtime Only. For transaction safety reasons, the collection agent needs to be followed by an Analysis or Aggregation agent, as each file received needs to be acknowledged with a reply to the collection agent. Based on the Batch SCP Collection Agent. Please refer to that package for more information. |
SCP Forwarding | Online | 8.0.4.0 | Forwards files to remote file system using the SCP protocol over SSH2. Uses the Standard File Forwarding Functions and File Forwarding Functions Available for Realtime Only. Based on the Batch SCP Forwarding Agent. Please refer to that package for more information. |
SFTP Collection Realtime
| Online | 8.0.4.0 | Continuously scans and collects files from remote file system using the SFTP protocol over SSH2. Uses the Standard File Collection Functions and File Collection Functions Available for Realtime Only. For transaction safety reasons, the collection agent needs to be followed by an Analysis or Aggregation agent, as each file received needs to be acknowledged with a reply to the collection agent. Based on the Batch SFTP Collection Agent. Please refer to that package for more information. |
SFTP Forwarding Realtime | Online | 8.0.4.0 | Forwards files to remote file system using the SFTP protocol over SSH2. Uses the Standard File Forwarding Functions and File Forwarding Functions Available for Realtime Only. Based on the Batch SFTP Forwarding Agent. Please refer to that package for more information. |
SNMP Request | Online | 7.3.5.0, 8.0.0.0 | Polls management and operational status data from SNMP-enabled network elements. The list of network elements to poll from is provided as a CSV file in the agent's configuration. The SNMP Collection profile is used to import the set of MIB files that will be used to build the target UDRs, as well as configure default parameters for connection. The SNMP OID Profile defines which UDR types and fields to poll.
|
SNMP Trap | Online | 7.3.5.0, 8.0.0.0 | Receives SNMP notifications, i e traps and informs. The SNMP Collection profile is used to import the set of MIB files that will be used to build the target UDRs, as well as configure default parameters for connection. |
SMPP Receiver | Online | 7.0.0.0 | Collects messages from SMSC (Short Message Service Center) and ESME (External Short Message Entity) using the SMPP (Short Message Peer to Peer) protocol. The configuration consists of connection details to the SMSC and ESME. Reference: |
SMPP Transmitter | Online | 7.0.0.0 | Forwards messages to SMSC (Short Message Service Center) and ESME (External Short Message Entity) using the SMPP (Short Message Peer to Peer) protocol. The configuration consists of connection details to the SMSC and ESME. Reference: |
SQL Realtime Forwarding | Online | 7.3.2.0 | Inserts UDR data into a database table according to configurable definitions of mapping between UDR fields and database table columns. Also, tables can be populated with MIM values using SQL statements or stored procedures. Commit frequency, queue sizes and exception handling is configurable. |
Syslog Collection | Online | 7.3.1.0 | Supports IPv4 and IPv6. Compliant with the specifications RFC5424 and RFC3164 (used when RFC5424 is not applicable). |
System Insight Collection | Online | 8.0.0.0 | Collects system insight data from the storage (Influx / Cloudwatch). |
System Insight Forwarding | Online | 8.0.0.0 | Sends SI UDRs to the storage (Inlux / Coudwatch). Note that you do not need this agent to send MIMs – this is configured in the Profile. Difference between MIM and SI UDR: → SI UDRs can have several labels associated with the name of the metric. MIMs only have the name of the metric. As an example; an SI UDR named "ORIGIN" can be associated with any number of labels, vs MIMs that need one MIM per origin ("AREA A", "AREA B", etc). → MIMs are automatically generated every 5 seconds. SI UDRs can be generated whenever. |
TCP/IP Collection | Online | 6.0.0.0 | Collects data via the standard TCP/IP protocol. Supports IPv4 and IPv6. Binds on a configurable port and allows multiple connections. Optionally, responses can be sent back (configured using the Analysis or Aggregation Agent). The agent has built-in support for decoding of data (configured using the Ultra Profile). |
TCP/IP Forwarding | Online | 7.0.0.0 | Forwards data via the standard TCP/IP protocol. Supports IPv4 and IPv6. Binds on a configurable port and allows multiple connections. Optionally, responses can be collected and processed by the workflow. All handling of responses is configured using Analysis or Aggregation agents. Contains configurable parameters for optimizing performance. |
UDP Collection | Online | 7.3.1.0 | Complies with the UDP protocol, RFC 768. Supports IPv4 and IPv6. Binds on a configurable port and allows multiple connections. Optionally, responses can be sent back (configured using the Analysis or Aggregation Agent). The agent has built-in support for decoding of data (configured using the Ultra Profile). |
Web Services | Online | 6.0.0.0 | Web Service agents communicate through SOAP in XML syntax, and use WSDL files. Server/Collection Client/Processing Web Services agents support:
|
Websocket | Online | 7.3.1.0 | Enables collection and forwarding of binary data and/or text frames from and to external web socket servers and clients. WebSocket is a protocol that enables bidirectional communication over a single TCP connection. References
|